How to public any service without public ip using OPENVPN.

How to public any service without public ip using OPENVPN.

Some time we want to publish our website or any service from our desktop to internet . Then we require public IP to publish our services on the internet.

So resolve this issue we can user third party services like PORTMAP.IO  this gives you ability to publish your services over the internet using OPEN VPN Client.

For more information visit there website https://portmap.io/

How to configure SSL VPN on OPENVPN

How to configure SSL VPN on OPENVPN

If you want to configure openvpn on SSL port below are the example for server and client side.

Server side configuration

local 192.168.1.250
port 443
proto tcp
dev tun
ca ca.crt
cert server.crt
key server.key
dh dh.pem
auth SHA512
tls-crypt tc.key
topology subnet
server 10.8.0.0 255.255.255.0
#server-ipv6 fddd:1194:1194:1194::/64
#push "redirect-gateway def1 ipv6 bypass-dhcp"  ## To avoid all internet traffic except VPN## 
push "route 192.168.29.0 255.255.255.0"         ## To advertise Network ##
ifconfig-pool-persist ipp.txt
push "dhcp-option DNS 192.168.29.254"
#push "dhcp-option DNS 8.8.4.4"
keepalive 10 120
cipher AES-256-CBC
user nobody
duplicate-cn                                    ##To use single certificate for multiple user#
group nobody
persist-key
persist-tun
verb 3
crl-verify crl.pem

Continue reading How to configure SSL VPN on OPENVPN

How to setup your IT Infrastructure for Work From Home

How to setup your IT Infrastructure for Work From Home in low cost with open source secure industry standard technologies.

Here I am going to talk about talk about small and medium size offices and companies who are not able to invest big amount to upgrade or migrate there IT infrastructure  for there workers to work from home in the COVID pandemic .

There are few things mostly you are using in the office as IT infrastructure as end user. if that IT infrastructure is available at your home then mostly people can work from home easily.

I am taking a small office example scenario with 30 employees which  you require to work from home.

Simple small office network diagram .

Continue reading How to setup your IT Infrastructure for Work From Home

How to Restart Management agents in ESXi Using ESXi Shell or Secure Shell (SSH)

How to Restart Management agents in ESXi Using ESXi Shell or Secure Shell (SSH).

  1. Log in to ESXi Shell or SSH as root.For Enabling ESXi Shell or SSH, see Using ESXi Shell in ESXi 5.x and 6.x

Restart the ESXi host daemon and vCenter Agent services using these commands:

/etc/init.d/hostd restart

/etc/init.d/vpxa restart

or

  • To reset the management network on a specific VMkernel interface, by default vmk0, run the command:esxcli network ip interface set -e false -i vmk0; esxcli network ip interface set -e true -i vmk0

    Note: Using a semicolon (;) between the two commands ensures the VMkernel interface is disabled and then re-enabled in succession. If the management interface is not running on vmk0, change the above command according to the VMkernel interface used.

  • To restart all management agents on the host, run the command:services.sh restart
  • original link

how to restart vmware esxi Network adapter

how to restart vmware esxi Network adapter

Login to VMware Esxi through ssh

check the network interfaces by following command .

# esxcli network nic list

----To  down your interface -----

# esxcli network nic down -n vmnicX                 X   replace X with your nic number

---To  make interface UP ---

# esxcli network nic up -n vmnicX

How to enable call forwarding from SIP extension Softphone or Analog Phone

How to enable call forwarding from SIP extension Softphone or Analog Phone if you are using Asterisk PBX or Issabel PBX .

From the Softphone or Analog Phone

Dial *72 with number where you want to forward the call for example I want to forward my all calls on

my mobile no 83199999 then i will dial  *7283199999      make sure you are able to dial outside from your phone . and add prefix which you dial for outside calls.

To Disable Call Forwarding

Dial *73

MikroTik DHCP Server configuration for multiple Networks

MikroTik DHCP Server configuration for multiple Networks

If you are having multiple Network  and want to configure DHCP server for your Networks .

Follow the steps and change the  IP Address and Interface names according to your requirement.

Here I will configure two networks for my home

1-   172.16.10.0/24   for my LAB

2- 10.34.200.0/24 for my Home

My Interfaces IP address

/ip address
add address=172.16.10.1/24 interface=ether2_lab network=172.16.10.0
add address=10.34.200.1/24 interface=ether3_home network=10.34.200.0

1- Create IP Pools for your Network

/ip pool
add name=lab ranges=172.16.10.100-172.16.10.150
add name=home ranges=10.34.200.100-10.34.200.150
add name=PPTP ranges=172.16.11.100-172.16.11.150

 

2- Create DHCP Server

/ip dhcp-server
add address-pool=lab disabled=no interface=ether2_lab name=dhcp1
add address-pool=home disabled=no interface=ether3_home name=server1

3- Create DHCP-Server Network

/ip dhcp-server network
add address=10.34.200.0/24 gateway=10.34.200.1
add address=172.16.10.0/24 gateway=172.16.10.1